ディモーラを使った遠隔録画予約(おまけ)

背景と検証内容

ディモーラを使用するため、ブロードバンドルータ(Cisco1812J)のスタティックNATの設定を行いましたが、ディモーラでではウェルノウン(well-known)ポート以外を使用しており、スタティックNATと既存で設定してあったPAT(IPマスカレード)を共存する形になりました。今回検証した内容は、ディモーラ宛にスタティックNATで設定したポート番号を、宅内にあるまったく別のPCで使用したら通信として成り立つかです。 

構成情報

装置 メーカ 機器名
ブロードバンドルータ シスコシステムズ Cisco1812J
HDD搭載DVDレコーダ パナソニック DIGA(DMR-XW31)
ノートPC 旧IBM Think Pad X21

<使用したツール>

パケットジェネレータ:IPSENDWIN

<NATの設定>

#インターネット向けインターフェースの設定
interface Dialer0
ip address negotiated
 ip access-group 101 in
 ip mtu 1454
 ip nat outside
 ip ips IPS in
 ip ips IPS out
 no ip virtual-reassembly
 encapsulation ppp
 ip tcp adjust-mss 1414
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp chap refuse
 ppp pap sent-username <ユーザ名> password 7<パスワード>

#宅内向けインターフェースの設定
interface Vlan1
 ip address 192.168.40.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly

#NATの設定
ip nat inside source list 111 interface Dialer0 overload ←PATの設定
ip nat inside source static tcp 192.168.40.6 47809 interface Dialer0 47809
ip nat inside source static udp 192.168.40.6 47810 interface Dialer0 47810
ip nat inside source static udp 192.168.40.6 47811 interface Dialer0 47811
ip nat inside source static udp 192.168.40.6 47812 interface Dialer0 47812
ip nat inside source static udp 192.168.40.6 47813 interface Dialer0 47813
ip nat inside source static udp 192.168.40.6 47814 interface Dialer0 47814
ip nat inside source static udp 192.168.40.6 47815 interface Dialer0 47815
ip nat inside source static udp 192.168.40.6 47816 interface Dialer0 47816
ip nat inside source static udp 192.168.40.6 47817 interface Dialer0 47817
ip nat inside source static udp 192.168.40.6 47818 interface Dialer0 47818
ip nat inside source static udp 192.168.40.6 47819 interface Dialer0 47819
ip nat inside source static udp 192.168.40.6 47820 interface Dialer0 47820
ip nat inside source static tcp 192.168.40.6 47825 interface Dialer0 47825
ip nat inside source static tcp 192.168.40.6 49000 interface Dialer0 49000
ip nat inside source static tcp 192.168.40.6 49001 interface Dialer0 49001
ip nat inside source static tcp 192.168.40.6 49002 interface Dialer0 49002
ip nat inside source static tcp 192.168.40.6 49003 interface Dialer0 49003
ip nat inside source static tcp 192.168.40.6 49004 interface Dialer0 49004
ip nat inside source static tcp 192.168.40.6 49005 interface Dialer0 49005
ip nat inside source static tcp 192.168.40.6 49006 interface Dialer0 49006
ip nat inside source static tcp 192.168.40.6 49007 interface Dialer0 49007
ip nat inside source static tcp 192.168.40.6 49008 interface Dialer0 49008
ip nat inside source static tcp 192.168.40.6 49009 interface Dialer0 49009
ip nat inside source static tcp 192.168.40.6 49010 interface Dialer0 49010
ip nat inside source static tcp 192.168.40.6 49011 interface Dialer0 49011
ip nat inside source static tcp 192.168.40.6 49012 interface Dialer0 49012
ip nat inside source static tcp 192.168.40.6 49013 interface Dialer0 49013
ip nat inside source static tcp 192.168.40.6 49014 interface Dialer0 49014
ip nat inside source static tcp 192.168.40.6 49015 interface Dialer0 49015
ip nat inside source static tcp 192.168.40.6 49016 interface Dialer0 49016
ip nat inside source static tcp 192.168.40.6 49017 interface Dialer0 49017
ip nat inside source static tcp 192.168.40.6 49018 interface Dialer0 49018
ip nat inside source static tcp 192.168.40.6 49019 interface Dialer0 49019
ip nat inside source static tcp 192.168.40.6 49020 interface Dialer0 49020
ip nat inside source static tcp 192.168.40.6 49021 interface Dialer0 49021
ip nat inside source static tcp 192.168.40.6 49022 interface Dialer0 49022
ip nat inside source static tcp 192.168.40.6 49023 interface Dialer0 49023
ip nat inside source static tcp 192.168.40.6 49024 interface Dialer0 49024
ip nat inside source static tcp 192.168.40.6 49025 interface Dialer0 49025
ip nat inside source static tcp 192.168.40.6 49026 interface Dialer0 49026
ip nat inside source static tcp 192.168.40.6 49027 interface Dialer0 49027
ip nat inside source static tcp 192.168.40.6 49028 interface Dialer0 49028
ip nat inside source static tcp 192.168.40.6 49029 interface Dialer0 49029
ip nat inside source static tcp 192.168.40.6 49030 interface Dialer0 49030
ip nat inside source static tcp 192.168.40.6 48810 interface Dialer0 48810

#PoolするプライベートIPアドレスの範囲
access-list 111 permit ip 192.168.40.0 0.0.0.255 any


検証結果

Ciscoのネットワーク製品ではスタティックNATで使用したポートを、宅内の別のPCが使用しても問題がありませんでした。
さて、ではどうして問題が発生しなかった理由ですが、スタティックNATとPAT(IPマスカレード)の特徴にあります。それぞれの特徴は以下の通りです。

  • スタティックNATの特徴

あるIPアドレス(またはポート番号)を、別のIPアドレス(またはポート番号)に変換する機能(1対1の対比)

  • PAT(IPマスカレード)の特徴

複数のプライベートIPアドレスを、一つのグローバルIPアドレスに変換する機能(プライベートIPアドレスは、グローバル側ではポート番号と紐づけて管理される)


分かりにくいかもしれませんが、以下に図を用意しました。ルータから左がインターネットで、ルータから右が宅内です。PATでは送信元ポートがルータで変換されていることに着目して下さい。

flow1.JPG

あと、スタティックNATのポートを使ってインターネットに通信した時のNATテーブルの抜粋です。DIGA(192.168.40.6)へのスタティックNATが有効になっていますが、PC(192.168.40.12)からの通信が行えていることが分かります。

#show ip nat translations
Pro Inside global            Inside local          Outside local        Outside global
tcpYY.155.XX.135:48810 192.168.40.6:48810  ---                     ---
tcpYY.155.XX.135:1097 192.168.40.12:48810 AA.83.BB.192:80 AA.83.BB.192:80

関連記事

人気記事のランキング

トラックバックURL

このエントリーのトラックバックURL:
http://or2.to/mt/mt-tb-mt.cgi/3

コメントする